BigInt not defined after changing eslist config env variables

1)Added the following according to tutorial in hello_frontend/package.json file

"env": {
  "es2020": true,
  "browser": true,
  "node": true,
  "mocha": true

2)got error after npm start
Line 29:18: ‘BigInt’ is not defined no-undef

3)Tried going back to package.json file and add in global declaration to no avail.

4)Do I have to reset blockchain? or am I missing something?

Hi @fovanessians please use this package.json in your front end project

  "name": "hello_frontend",
  "version": "0.1.0",
  "private": true,
  "dependencies": {
    "@liskhq/lisk-client": "^5.2.1",
    "@testing-library/jest-dom": "^5.11.4",
    "@testing-library/react": "^11.1.0",
    "@testing-library/user-event": "^12.1.10",
    "react": "^17.0.2",
    "react-dom": "^17.0.2",
    "react-router-dom": "^5.2.0",
    "react-scripts": "4.0.3",
    "web-vitals": "^1.0.1"
  "scripts": {
    "start": "react-scripts start",
    "build": "react-scripts build",
    "test": "react-scripts test",
    "eject": "react-scripts eject"
  "eslintConfig": {
    "extends": [
    "env": {
      "es2020": true,
      "browser": true,
      "node": true,
      "mocha": true
  "browserslist": {
    "production": [
      "not dead",
      "not op_mini all"
    "development": [
      "last 1 chrome version",
      "last 1 firefox version",
      "last 1 safari version"

and then do npm i to install the dependancies, it seems like react-scripts@3.1.1 is to low for BigInt support

Later on you may encounter account has been already declared error in Faucet.js if yes, then comment the import accounts from '../accounts.json'; line in the Faucet.js file. Remember about providing a proper passphrase with funds on it for the faucet.

I will go thru the ‘enabling a faucet lesson’ then. However, I did get warnings, but they appear to be for when the blockchain is running. The npm node script starts the front end, but my blockchain is not running.

Line 1:10: ‘cryptography’ is defined but never used no-unused-vars
Line 2:17: ‘Component’ is defined but never used no-unused-vars

Line 1:17: ‘Component’ is defined but never used no-unused-vars

Search for the keywords to learn more about each warning.
To ignore, add // eslint-disable-next-line to the line before.

Those warning shouldn’t matter. You need to run your hello_app blockchain separately. With ./bin/run start --api-ws